Cruisers Forum

Main Forum => General Discussion => Topic started by: rvrunner on January 04, 2019, 08:57:48 pm

Title: Tank Sprayers
Post by: rvrunner on January 04, 2019, 08:57:48 pm
After dumping I turn the black valve, then turn on the water to flush the black tank. you can here the water spraying inside the tank. Tried this a while back, I heard a pop and the water stopped spraying. I looked in the black tank and water was running in but not spraying around. Yesterday the same thing happened to the gray tank sprayer, what gives?

   Lynn
Title: Re: Tank Sprayers
Post by: ragoodsp on January 05, 2019, 01:52:33 pm
The jets are plugged. There are three screws thatís hold the fixture in the tank. Disconnect the water supply line to the fixture.  Remove and clean the jets.  Use clear silicon to create a good seal  between tank and fixture when you reinstall .  Do not over tighten the screws!  Very easy job, maybe 30 mins.  Not sure it will unplug itself but keep running high pressure water thru if you desire.  Good luck
Title: Re: Tank Sprayers
Post by: rvrunner on January 05, 2019, 07:40:42 pm
The jets are plugged. There are three screws thatís hold the fixture in the tank. Disconnect the water supply line to the fixture.  Remove and clean the jets.  Use clear silicon to create a good seal  between tank and fixture when you reinstall .  Do not over tighten the screws!  Very easy job, maybe 30 mins.  Not sure it will unplug itself but keep running high pressure water thru if you desire.  Good luck
Thank you. I think I'll wait till I get home this spring to fix. Maybe I should use a filter on my flush hose?

  Lynn
Title: Re: Tank Sprayers
Post by: ragoodsp on January 06, 2019, 11:44:25 am
Not sure there is much you can do Lynn
to prevent what has happened. It is what is in the tank that plugs the jets.  You might try some tank cleaner additive but I am afraid it is the nature of the beast.  Good luck
Title: Re: Tank Sprayers
Post by: donc13 on January 06, 2019, 06:50:29 pm
After dumping I turn the black valve, then turn on the water to flush the black tank. you can here the water spraying inside the tank. Tried this a while back, I heard a pop and the water stopped spraying. I looked in the black tank and water was running in but not spraying around. Yesterday the same thing happened to the gray tank sprayer, what gives?

   Lynn

The flush valves should be turned on while you are dumping.   Start with the black tank. Open tank valve, turn on macerator, then turn on the water flush.   Once tank is dumped turn off macerator, close flush valve, wait 30 seconds or so, close tank valve.  Then turn macerator back on for a few seconds.  Repeat with grey tank.
Title: Re: Tank Sprayers
Post by: 2 Frazzled on January 07, 2019, 05:31:11 am
Lynn, I don't remember reading anything like this before. I doubt they are clogged from stuff in the tank. That would happen one by one not all at once in one tank then again for the other. It also doesn't explain the popping noise. My first thought was the water supply disconnected but you get water. Maybe it's a partial disconnect and water runs out under the rig? (Hopefully it would run out, not in - never looked at hookup for sprayers). I'm just guessing here. I suggest a call to the factory.
Title: Re: Tank Sprayers
Post by: rvrunner on January 07, 2019, 03:37:24 pm
I dumped this morning and both sprayers worked, go figure.

   Lynn